Excel szkolenia



Excel funkcja INDEKS ()

Opis

INDEKS()

Funkcja INDEKS() służy do zwracania wartości lub odwołania do wartości która jest w tablicy lub zakresie (wskazanej w parametrach tej funkcji). Funkcja może mieć "formę tablicową" i "formę odwołania", co będzie wyjaśnione w poniższych przykładach.

Składnia

Forma tablicowa

=INDEKS( tablica ; numer_wiersza ; [numer_kolumny])

Forma odwołania

=INDEKS( odwołanie ; numer_wiersza ; [numer_kolumny] ; [numer_obszaru])

Przykłady

Forma tablicowa

Poniżej przygotowałem przykładową tabelę. Jest to tabela z listą zakupów.

Funkcja w tej formie zwróci wartość wskazaną w argumentach funkcji, czyli na początku wskazujemy gdzie nasza tabela znajduje się w naszym arkuszu. W naszym przypadku będzie to zakres od A2 do E20, czyli zapiszemy A2:E20. Następnie, zgodnie ze składnią, wskazujemy numer wiersza np. 3 i numer kolumny np. 2. W ten sposób nasza cała formuła przyjmie postać =INDEKS(A2:E20;3;2). W wyniku działania naszej funkcji INDEKS powinniśmy otrzymać słowo "Jabłka". Poniżej jeszcze kilka przykładów.

Formuła Wynik Opis
=INDEKS(A2:E20;8;5) 3,4 Wartość wskazana w argumentach funkcji. Tabela = A2:E20, numer wiersza = 8, numer kolumny = 5.
=INDEKS(E2:E20;19;1) 1,2 Wartość wskazana w argumentach funkcji. Tabela = E2:E20, numer wiersza = 19, numer kolumny = 1.
=INDEKS(A2:C20;16;2) Kawa Wartość wskazana w argumentach funkcji. Tabela = A2:C20, numer wiersza = 16, numer kolumny = 2.

PAMIĘTAJ

Jeżeli korzystasz z tej formy i wpisujesz numer wiersza i kolumny to wskazana komórka (przecięcie wiersza i kolumny muszą się znaleźć wewnątrz wskazanej tabeli.
Parametr "numer kolumny" jest fakultatywny ale tylko wtedy kiedy tabela ma jedną kolumnę, w innym przypadku funkcja zwróci nam bład (#ADR!).

Forma odwołania

Posłużę się tym samym przykładem jak wyżej.

Przy formie odwołania możemy w pierwszym argumencie wskazać kilka zakresów komórek. Wtedy każdy z zakresów oddzialamy znakiem ";" i wszystkie zakresy bierzemy w dodatkowy nawias np. (A1:B10;E3:E10). Wtedy w czwatym argumencie "numer_obszaru" wskazujemy z którego obszaru chcemy pobrać wartość. Poniżej kilka przykładów dla tej formy.

Formuła Wynik Opis
=INDEKS((A2:E20;C2:E20);3;2;1) Jabłka Wartość wskazana w argumentach funkcji. Odwołania/zakresy = (A2:E20;C2:E20), czyli mamy 2 zakresy, numer wiersza = 3, numer kolumny = 2, numer zakresu = 1 (czyli korzystamy z zakresu A2:E20).
=INDEKS((A2:E20;C2:E20);3;2;2) 1 Formuła identyczna jak powyżej z tą różnicą że w ostatnim argumencie "numer zakresu" wskazany jest drugi zakres czyli C2:E20. Wtedy wskazaną wartością będzie 1.